You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 

68 lines
1.5 KiB

%global git0 https://github.com/rootless-containers/%{name}
%global commit0 eecccdb96f587b11d7764556ffacfeaffe4b6e11
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
# Used for comparing with latest upstream tag
# to decide whether to autobuild (non-rawhide only)
%global built_tag v1.0.0
Name: slirp4netns
Version: 1.1.4
Release: 1%{?dist}
# no go-md2man in ppc64
#ExcludeArch: ppc64
Summary: slirp for network namespaces
License: GPLv2
URL: %{git0}
Source0: %{git0}/archive/%{commit0}/%{name}-%{shortcommit0}.tar.gz
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: gcc
BuildRequires: glib2-devel
BuildRequires: git
BuildRequires: go-md2man
BuildRequires: libcap-devel
BuildRequires: libseccomp-devel
BuildRequires: libslirp-devel
BuildRequires: make
%description
slirp for network namespaces, without copying buffers across the namespaces.
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
%{summary}
This package contains library source intended for
building other packages which use import path with
%{import_path} prefix.
%prep
%autosetup -Sgit -n %{name}-%{commit0}
%build
export CFLAGS="%{optflags}"
export CXXFLAGS="%{optflags}"
export GCCFLAGS="%{optflags}"
./autogen.sh
./configure --prefix=%{_usr} --libdir=%{_libdir}
%{__make} generate-man
%install
make DESTDIR=%{buildroot} install install-man
%check
#define license tag if not already defined
%{!?_licensedir:%global license %doc}
%files
%license COPYING
%doc README.md
%{_bindir}/%{name}
%{_mandir}/man1/%{name}.1.gz
%changelog