You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

68 lines
2.5 KiB

%global srcname typing_extensions
Name: python-typing-extensions
Version: 3.7.4.3
Release: 1%{?dist}
Summary: Python Typing Extensions
License: Python
URL: https://pypi.org/project/typing-extensions/
Source0: %{srcname}-%{version}.tar.gz
BuildArch: noarch
%description
Typing Extensions - Backported and Experimental Type Hints for Python
The typing module was added to the standard library in Python 3.5 on a
provisional basis and will no longer be provisional in Python 3.7.
However, this means users of Python 3.5 - 3.6 who are unable to upgrade will not
be able to take advantage of new types added to the typing module, such as
typing.Text or typing.Coroutine.
The typing_extensions module contains both backports of these changes as well as
experimental types that will eventually be added to the typing module, such as
Protocol.
Users of other Python versions should continue to install and use the typing
module from PyPi instead of using this one unless specifically writing code that
must be compatible with multiple Python versions or requires experimental types.
%package -n python3-typing-extensions
Summary: %{summary}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%{?python_provide:%python_provide python3-%{srcname}}
%description -n python3-typing-extensions
Typing Extensions - Backported and Experimental Type Hints for Python
The typing module was added to the standard library in Python 3.5 on a
provisional basis and will no longer be provisional in Python 3.7.
However, this means users of Python 3.5 - 3.6 who are unable to upgrade will not
be able to take advantage of new types added to the typing module, such as
typing.Text or typing.Coroutine.
The typing_extensions module contains both backports of these changes as well as
experimental types that will eventually be added to the typing module, such as
Protocol.
Users of other Python versions should continue to install and use the typing
module from PyPi instead of using this one unless specifically writing code that
must be compatible with multiple Python versions or requires experimental types.
%prep
%autosetup -n %{srcname}-%{version} -p2
%build
%{__python3} setup.py build
%install
%{__python3} setup.py install --optimize 2 --root %{buildroot}
%files -n python3-typing-extensions
%license LICENSE
%doc README.rst
%{python3_sitelib}/%{srcname}-*.egg-info/
%{python3_sitelib}/%{srcname}.py
%{python3_sitelib}/__pycache__/*
%changelog