You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

199 lines
7.5 KiB

Name: perl-B-Hooks-EndOfScope
Version: 0.13
Release: 2%{?dist}
License: GPL+ or Artistic
Group: Development/Libraries
Summary: Execute code after scope compilation finishes
URL: http://search.cpan.org/dist/B-Hooks-EndOfScope/
Source0: http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/B-Hooks-EndOfScope-%{version}.tar.gz
Patch0: B-Hooks-EndOfScope-0.13-shellbangs.patch
BuildArch: noarch
# Build
BuildRequires: perl(ExtUtils::CBuilder)
BuildRequires: perl(ExtUtils::MakeMaker)
# Module
# note: Variable::Magic only needed (version ≥ 0.48) by XS version
# base, constant, Hash::Util::FieldHash and Scalar::Util only needed by PP version
BuildRequires: perl(base)
BuildRequires: perl(constant)
BuildRequires: perl(Hash::Util::FieldHash)
BuildRequires: perl(Module::Implementation) >= 0.05
BuildRequires: perl(Module::Runtime) >= 0.012
BuildRequires: perl(Scalar::Util)
BuildRequires: perl(Sub::Exporter::Progressive) >= 0.001006
BuildRequires: perl(Variable::Magic) >= 0.48
# Test suite
BuildRequires: perl(CPAN::Meta)
BuildRequires: perl(CPAN::Meta::Requirements)
BuildRequires: perl(Devel::Hide) >= 0.0007
BuildRequires: perl(Test::More) >= 0.89
# Release tests
%if 0%{!?perl_bootstrap:1} && 0%{?rhel} < 7
BuildRequires: perl(Pod::Coverage::TrustPod)
BuildRequires: perl(Test::CPAN::Changes)
BuildRequires: perl(Test::CPAN::Meta)
BuildRequires: perl(Test::EOL)
BuildRequires: perl(Test::Kwalitee)
BuildRequires: perl(Test::MinimumVersion)
BuildRequires: perl(Test::Mojibake)
BuildRequires: perl(Test::NoTabs)
BuildRequires: perl(Test::Pod) >= 1.41
BuildRequires: perl(Test::Pod::Coverage) >= 1.08
BuildRequires: perl(Test::Pod::No404s)
BuildRequires: perl(Test::Portability::Files)
BuildRequires: perl(Test::Spelling), hunspell-en
BuildRequires: perl(Test::Vars)
BuildRequires: perl(Test::Version)
%endif
# Runtime
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
Requires: perl(Module::Implementation) >= 0.05
Requires: perl(Module::Runtime) >= 0.012
Requires: perl(Variable::Magic) >= 0.48
%description
This module allows you to execute code when Perl has finished compiling the
surrounding scope.
%prep
%setup -q -n B-Hooks-EndOfScope-%{version}
# Remove shellbangs from tests to placate rpmlint
%patch0
%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
%install
make pure_install DESTDIR=%{buildroot}
find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
%{_fixperms} %{buildroot}
%check
export AUTHOR_TESTING=1
make test
%if 0%{!?perl_bootstrap:1} && 0%{?rhel} < 7
make test TEST_FILES="$(echo $(find xt/ -name '*.t'))"
%endif
%files
%doc Changes CONTRIBUTING LICENSE README README.md t/
%{perl_vendorlib}/B/
%{_mandir}/man3/B::Hooks::EndOfScope.3pm*
%{_mandir}/man3/B::Hooks::EndOfScope::PP.3pm*
%{_mandir}/man3/B::Hooks::EndOfScope::XS.3pm*
%changelog
* Wed Jan 15 2014 Paul Howarth <paul@city-fan.org> - 0.13-2
- Bootstrap EPEL-7 build
* Wed Jan 8 2014 Paul Howarth <paul@city-fan.org> - 0.13-1
- Update to 0.13
- Variable::Magic added as a runtime recommendation for greater visibility
(CPAN RT#89245)
- Fixed broken logic in compiler detection on older perls
- Fixed inaccurate repository metadata
- This release by ETHER -> update source URL
- Drop Pod Coverage patch, no longer needed
- Update shellbang patch
- Don't run the release tests when bootstrapping
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Wed Jul 24 2013 Petr Pisar <ppisar@redhat.com> - 0.12-3
- Perl 5.18 rebuild
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Wed Dec 5 2012 Paul Howarth <paul@city-fan.org> - 0.12-1
- Update to 0.12
- Complete pure-perl implementation in addition to the one based on
Variable::Magic; you can specify the implementation explicitly by use-ing
B::Hooks::EndOfScope::PP or B::Hooks::EndOfScope::XS, or by setting
$ENV{B_HOOKS_ENDOFSCOPE_IMPLEMENTATION} to either 'XS' or 'PP'
- Switch from using Sub::Exporter to the more conservative
Sub::Exporter::Progressive
- Add patch to fix POD coverage issues in new pure-perl implementation
- This release by BOBTFISH -> update source URL
- BR: perl(ExtUtils::CBuilder) ≥ 0.26, perl(Devel::Hide) ≥ 0.0007,
perl(Module::Implementation) ≥ 0.05 and perl(Module::Runtime) ≥ 0.012
- BR: perl(Sub::Exporter::Progressive) rather than perl(Sub::Exporter)
- BR: perl(base), perl(constant), perl(Hash::Util::FieldHash) and
perl(Scalar::Util) for the pure-perl implementation
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Fri Jun 15 2012 Petr Pisar <ppisar@redhat.com> - 0.11-2
- Perl 5.16 rebuild
* Thu Feb 23 2012 Paul Howarth <paul@city-fan.org> - 0.11-1
- Update to 0.11 (a minor efficiency improvement)
- Bump perl(Variable::Magic) version requirement to 0.48
* Thu Feb 16 2012 Paul Howarth <paul@city-fan.org> - 0.10-1
- Update to 0.10 (stop propagating our magic through localisation)
- Package LICENSE file
- Downgrade ExtUtils::MakeMaker version requirement to 6.30
- Upgrade Test::More version requirement to 0.89
- Drop Test::Pod version requirement for EPEL-6 spec compatibility
- BR: perl(Test::EOL) and perl(Test::NoTabs) for additional test coverage
- Clean up for modern rpmbuild since we have no branches prior to EPEL-6
- Don't specify BuildRoot:
- Skip cleaning of buildroot in %%install
- Remove %%clean section
- Drop redundant %%defattr
- Remove shellbangs from tests to placate rpmlint
* Tue Jan 17 2012 Paul Howarth <paul@city-fan.org> - 0.09-1
- Update to 0.09 (improve distribution metadata)
- Run release tests too
- BR: perl(Pod::Coverage::TrustPod), perl(Test::Pod) and
perl(Test::Pod::Coverage) for release tests
- Spec clean-up:
- Make %%files list more explicit
- Use DESTDIR rather than PERL_INSTALL_ROOT
- Use tabs
- Split buildreqs by Build/Module/Tests/Release tests
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.08-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.08-7
- Perl mass rebuild
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.08-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.08-5
- Rebuild to fix problems with vendorarch/lib (#661697)
* Thu Apr 29 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.08-4
- Mass rebuild with perl-5.12.0
* Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.08-3
- rebuild against perl 5.10.1
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.08-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Sun May 17 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.08-1
- auto-update to 0.08 (by cpan-spec-update 0.01)
- altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
- altered br on perl(Variable::Magic) (0.31 => 0.34)
* Sun Mar 08 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.07-1
- update to 0.07
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.04-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.04-1
- update for submission
* Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.04-0.1
- initial RPM packaging
- generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.5)