You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 

54 lines
1.0 KiB

%global module_name grafana
%global icingaweb_min_version 2.6.0
%global basedir %{_datadir}/icingaweb2/modules/%{module_name}
Name: icingaweb2-module-%{module_name}
Version: 2.0.3
Release: 1%{?dist}
Summary: Grafana - Icinga Web 2 module
Group: Applications/System
License: GPLv2+
URL: https://icinga.com
Source0: https://github.com/Mikesch-mp/icingaweb2-module-%{module_name}/archive/v%{version}.tar.gz
BuildArch: noarch
Requires: icingaweb2 >= %{icingaweb_min_version}
Requires: php-Icinga >= %{icingaweb_min_version}
%description
Grafana module for Icinga Web 2.
%prep
%setup -q
%build
%install
rm -rf %{buildroot}
mkdir -p %{buildroot}%{basedir}
cp -r * %{buildroot}%{basedir}
%clean
rm -rf %{buildroot}
%preun
set -e
if [ $1 == 0 ]; then
echo "Disabling icingaweb2 module '%{module_name}'"
rm -f /etc/icingaweb2/enabledModules/%{module_name}
fi
exit 0
%files
%doc README.md LICENSE
%defattr(-,root,root)
%{basedir}
%changelog