You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

195 lines
6.7 KiB

%global rpmmacrodir %{_sysconfdir}/rpm
Name: python-rpm-macros
Version: 3
Release: 34%{?dist}
Summary: The unversioned Python RPM macros
License: MIT
Source0: macros.python
Source1: macros.python-srpm
Source2: macros.python2
Source3: macros.python3
Source4: macros.pybytecompile
BuildArch: noarch
# The macro file has been moved from the python-devel package
Conflicts: python-devel < 2.7.5-78
# For %%python3_pkgversion used in %%python_provide
Requires: python-srpm-macros
%description
This package contains the unversioned Python RPM macros, that most
implementations should rely on.
You should not need to install this package manually as the various
python?-devel packages require it. So install a python-devel package instead.
%package -n python-srpm-macros
Summary: RPM macros for building Python source packages
%description -n python-srpm-macros
RPM macros for building Python source packages.
%package -n python2-rpm-macros
Summary: RPM macros for building Python 2 packages
# The macro file has been moved from the python-devel package
Conflicts: python-devel < 2.7.5-78
%description -n python2-rpm-macros
RPM macros for building Python 2 packages.
%package -n python3-rpm-macros
Summary: RPM macros for building Python 3 packages
# Would need to be different for each release - worth it?
#Conflicts: python3-devel < 3.5.1-3
%description -n python3-rpm-macros
RPM macros for building Python 3 packages.
%prep
%build
%install
mkdir -p %{buildroot}/%{_sysconfdir}/rpm
mkdir -p %{buildroot}/%{rpmmacrodir}
install -m 644 %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} \
%{buildroot}/%{_sysconfdir}/rpm/
%files
%{rpmmacrodir}/macros.python
%{rpmmacrodir}/macros.pybytecompile
%files -n python-srpm-macros
%{rpmmacrodir}/macros.python-srpm
%files -n python2-rpm-macros
%{rpmmacrodir}/macros.python2
%files -n python3-rpm-macros
%{rpmmacrodir}/macros.python3
%changelog
* Tue Mar 17 2020 Miro Hrončok <mhroncok@redhat.com> - 3-34
- Make the %%py3_dist macro compatible with Python RPM generators
Resolves: rhbz#1812665
* Wed Mar 04 2020 Charalampos Stratakis <cstratak@redhat.com> - 3-33
- Fix the %%py_build macro to respect the global definition of %%__python
Resolves: rhbz#1757834
* Wed Apr 24 2019 Miro Hrončok <mhroncok@redhat.com> - 3-32
- %%python_provide: Obsolete and provide python36- from python3-
- %%python_provide: Provide python3- from python36-
Resolves: rhbz#1702719
* Mon Jan 14 2019 Lumír Balhar <lbalhar@redhat.com> - 3-31
- Converting specfile from F28 to RHEL7
- Move the macros to the standard RHEL7 macro location at /etc/rpm/,
instead of Fedora's location at /usr/lib/rpm/macros.d/
- Import the macros.python{,2} files from the python-devel package where they
resided until now, and Conflict with that old version of python-devel
- Import the macros.pybytecompile from Fedora rawhide / RHEL8
Resolves: rhbz#1660579
* Mon Jul 09 2018 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-30
- Backport %%python3_platform macro.
* Mon Jun 18 2018 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-29
- Add %%pypi_source macro.
* Fri Apr 06 2018 Tomas Orsava <torsava@redhat.com> - 3-28
- Fix the %%py_dist_name macro to not convert dots (".") into dashes, so that
submodules can be addressed as well Resolves: rhbz#1564095
* Fri Mar 23 2018 Miro Hrončok <mhroncok@redhat.com> - 3-27
- make LDFLAGS propagated whenever CFLAGS are
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3-26
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Fri Jan 19 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3-25
- Add %%python_enable_dependency_generator
* Tue Nov 28 2017 Tomas Orsava <torsava@redhat.com> - 3-24
- Remove platform-python macros (https://fedoraproject.org/wiki/Changes/Platform_Python_Stack)
* Thu Oct 26 2017 Ville Skyttä <ville.skytta@iki.fi> - 3-23
- Use -Es/-I to invoke macro scriptlets (#1506355)
* Wed Aug 02 2017 Tomas Orsava <torsava@redhat.com> - 3-22
- Add platform-python macros (https://fedoraproject.org/wiki/Changes/Platform_Python_Stack)
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-21
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Mar 03 2017 Michal Cyprian <mcyprian@redhat.com> - 3-20
- Revert "Switch %%__python3 to /usr/libexec/system-python"
after the Fedora Change https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
was postponed
* Fri Feb 17 2017 Michal Cyprian <mcyprian@redhat.com> - 3-19
- Switch %%__python3 to /usr/libexec/system-python
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-18
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Mon Jan 23 2017 Michal Cyprian <mcyprian@redhat.com> - 3-17
- Add --no-deps option to py_install_wheel macros
* Tue Jan 17 2017 Tomas Orsava <torsava@redhat.com> - 3-16
- Added macros for Build/Requires tags using Python dist tags:
https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
* Thu Nov 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-15
- Make expanded macros start on the same line as the macro
* Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-14
- Fix %%py3_install_wheel (bug #1395953)
* Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-13
- Add missing sleeps to other build macros
- Fix build_egg macros
- Add %%py_build_wheel and %%py_install_wheel macros
* Tue Nov 15 2016 Orion Poplawski <orion@cora.nwra.com> 3-12
- Add %%py_build_egg and %%py_install_egg macros
- Allow multiple args to %%py_build/install macros
- Tidy up macro formatting
* Wed Aug 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-11
- Use %%rpmmacrodir
* Tue Jul 12 2016 Orion Poplawski <orion@cora.nwra.com> 3-10
- Do not generate useless Obsoletes with %%{?_isa}
* Fri May 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-9
- Make python-rpm-macros require python-srpm-macros (bug #1335860)
* Thu May 12 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-8
- Add single-second sleeps to work around setuptools bug.
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-6
- Fix typo in %%python_provide
* Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-5
- Handle noarch python sub-packages (bug #1290900)
* Wed Jan 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-4
- Fix python2/3-rpm-macros package names
* Thu Jan 7 2016 Orion Poplawski <orion@cora.nwra.com> 3-3
- Add empty %%prep and %%build
* Mon Jan 4 2016 Orion Poplawski <orion@cora.nwra.com> 3-2
- Combined package
* Wed Dec 30 2015 Orion Poplawski <orion@cora.nwra.com> 3-1
- Initial package