You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

87 lines
2.5 KiB

Name: perl-autodie
Version: 2.16
Release: 2%{?dist}
Summary: Replace functions with ones that succeed or die
License: GPL+ or Artistic
Group: Development/Libraries
URL: http://search.cpan.org/dist/autodie/
Source0: http://www.cpan.org/authors/id/P/PJ/PJF/autodie-%{version}.tar.gz
BuildArch: noarch
BuildRequires: perl
# Stick on bundled inc::Module::Install to allow boot-straping this core package
BuildRequires: perl(Config)
BuildRequires: perl(Cwd)
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(ExtUtils::MM_Unix)
BuildRequires: perl(FindBin)
BuildRequires: perl(File::Find)
BuildRequires: perl(File::Path)
BuildRequires: perl(strict)
BuildRequires: perl(vars)
# Run-time:
BuildRequires: perl(B)
BuildRequires: perl(base)
BuildRequires: perl(Carp)
BuildRequires: perl(constant)
BuildRequires: perl(Exporter)
BuildRequires: perl(Fcntl)
BuildRequires: perl(if)
# Keep IPC::System::Simple 0.12 optional
BuildRequires: perl(overload)
BuildRequires: perl(POSIX)
BuildRequires: perl(Tie::RefHash)
# Sub::Identify is optional
BuildRequires: perl(warnings)
# Tests:
BuildRequires: perl(lib)
BuildRequires: perl(File::Copy)
BuildRequires: perl(File::Spec)
BuildRequires: perl(File::Temp)
BuildRequires: perl(IO::Handle)
BuildRequires: perl(open)
BuildRequires: perl(Socket)
BuildRequires: perl(Test::More)
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
Requires: perl(B)
Requires: perl(Fcntl)
Requires: perl(overload)
Requires: perl(POSIX)
%description
The "autodie" and "Fatal" pragma provides a convenient way to replace
functions that normally return false on failure with equivalents that throw an
exception on failure.
However "Fatal" has been obsoleted by the new autodie pragma. Please use
autodie in preference to "Fatal".
%prep
%setup -q -n autodie-%{version}
find -type f -exec chmod -x {} +
%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
%install
make pure_install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
%{_fixperms} $RPM_BUILD_ROOT/*
%check
make test
%files
%doc AUTHORS Changes LICENSE README
%{perl_vendorlib}/*
%{_mandir}/man3/*
%changelog
* Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 2.16-2
- Mass rebuild 2013-12-27
* Wed Mar 06 2013 Petr Pisar <ppisar@redhat.com> - 2.16-1
- 2.16 bump
* Thu Feb 14 2013 Petr Pisar <ppisar@redhat.com> 2.13-1
- Specfile autogenerated by cpanspec 1.78.